+1
The problem with #ensure style selectors is that they are confusing because they both test something and maybe do something to create a certain condition. The only way to take away the confusion is to make a very long selector. That is why comments are also important.
Like Stef said, this was already debated for quite some time. The current choice is maybe not perfect, there is nothing stopping anyone from suggesting a better alternative. Good luck with getting a consensus.
On 25 Oct 2013, at 15:28, Norbert Hartl <norbert@hartl.name> wrote:
Stef,
I really donât want to stretch this into an argue â¦. but I have problems understanding that. There are refactorings of method selectors because it is said it is important that includesSubString: is written as includesSubstring: and there are other examples. Now we have a selector that people find confusing and that is not important? I donât understand it and the only difference I can see by now is the way you or your team is involved in the action. So the only thing I would understand is sensitivities meaning you are sick of complaints regarding your work. Otherwise I donât understand that.
Norbert
Am 25.10.2013 um 15:04 schrieb Stéphane Ducasse <stephane.ducasse@inria.fr>:
can we focus on real problems? The method has a comment.
Stef
On Oct 25, 2013, at 10:39 AM, Norbert Hartl <norbert@hartl.name> wrote:
Am 25.10.2013 um 10:11 schrieb Nicolas Cellier <nicolas.cellier.aka.nice@gmail.com>:
So action=create object=directory you want to be sure that you create a directory? What if it already exists? Since you want to be sure to create, will you erase and re-create? You see the kind of misunderstanding this could create... IOW, self ensureCreateMisunderstanding
+1 I didnât like it in the first place. It is just confusing. And probably an example how hard it can be if two or more non-native speaker try to find something that makes sense.
Norbert
2013/10/25 Stéphane Ducasse <stephane.ducasse@inria.fr> Consistency ensureActionObject
ensureCreateDirectory ensureCreateFile
We discuss a lot with camillo when we did it and I think that this is good right now.
Out of curiosity, what was the motivation behind Issue 10924: Simplifying ensure* and create protocol?
For me #ensureCreateDirectory is less intention revealing than #ensureDirectory because the "ensure" means "create only if necessary", not "definitely create" a directory. What am I missing? Thanks.
----- Cheers, Sean -- View this message in context: http://forum.world.st/ensureCreateDirectory-tp4716925.html Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.