On Mar 2, 2009, at 09:00 , Stéphane Ducasse wrote:
This reminds me some thoughts about time and date.
Originally date and time were ok but not so great. Then one guy (brent) fixed it and people were happy and it was introduced in the base system. At that time when time was introduced (in 3.7 I guess) it was a obvious choice. Then chronos and aconcagua went out showing some other properties.
Now retrospectively I think that it would be better to have a minimal version in the system and loadable external package. There are some exceptions to this strategy: announcements and regexp (where this is more a language decision), but in general this is a good strategy
I think a good rule of thumb is whether the code is used by the kernel. Having packages like Regex and Announcements in the core makes only sense if they are also used in the core. Else they would better be external packages. Not sure about median, though, as for just one method you wouldn't want to create and load an extra package... Adrian
So we could rename median naiveMedian and have a package that does all the rest and that people can load it.
Stef
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project