Nov. 15, 2013
1:06 p.m.
Hi, I looked at the implementation of #linesOfCode of ClassDescription. It is actually wrong, a correct version should be: linesOfCode "An approximate measure of lines of code. Includes comments, but excludes blank lines." | lines | lines := self localMethods inject: 0 into: [:sum :each | sum + each linesOfCode]. ^ self isMeta not ifTrue: [lines] ifFalse: [lines + self class linesOfCode] Cheers, Roby