I prefer ban this rule = do not run it false positive = rule is ok but wrong here
Do you mean ban rule completely? On which level? For a developer (machine)?
in the codecritcis the scope is clear. On a class or a package.
Then again, skip works as former âfalse positiveâ. But in my opinion âfalse positiveâ is not a good name from the logical point of view. You have a rule that detects if you have no #yourself message in the end of a cascade. Now do people really mark this as âfalse positiveâ if the rule detects cascades that have #yourself message in the end? Or they do it if they donât want to see the critic? Then itâs not false positive, then they just want to hide or âskipâ the rule. Sorry but I do not understand your argument. For me this is simple: the rule tells me something is wrong and it is not. -> so I mark it as false positive.
This is fun part from statistics to name things as false positives. But if we program a rule in such way, that it is fuzzy, I think that itâs not correct to call it as false positive. Maybe itâs critics are useless more times that they are helpful, and if the critic is correct, the issue is not that important. Then probably we should just remove the rule or rewrite it.
Now with useless button, the only reason is to collect data on which rules are actually useless to people [1], so we can take a look at them in a first place. It doest not affect the functionality.
I do not like useless. Because it is too violent and unclear. Please again have a look at the vocabulary used in the CodeCritics and the chapter that describes it. Or you should fix everything but we should not have two different vocabularies. There is enough confusing terms in Pharo so that we do not add more. Stef
Uko
[1]: http://renraku.inf.usi.ch/rules
Stef
Uko
On 23 Jul 2015, at 22:29, stepharo <stepharo@free.fr <mailto:stepharo@free.fr>> wrote:
HI yuriy
it would be good that quality assistant uses the same vocabulary than codecritics. for example skip -> ban? marks as false positif?
Stef