Does someone know what "gently" means for ? it asks " S'il vous plait " to each class ? Seriously, I don't understand. What about rename it to something like: allSubclassesInMemoryDo ? what do you think ? On Sun, Jan 17, 2010 at 10:34 PM, Stéphane Ducasse < stephane.ducasse@inria.fr> wrote:
Yes of course. Now since only a subpart of the system was using it it means that imageSegment are most of the time reloaded. So this is clearly a neat idea but not fully working.
Stef
On Jan 17, 2010, at 10:27 PM, John M McIntosh wrote:
I think you'll find it's documented in the class ImageSegmentRootStub
It's all tied up in image segments, projects, etoys and the like, so in the past an attempt to ensure that objects (classes) that were bundled up and stuffed into an image segment aren't faulted back in unless you really mean it...
users of this are interesting, see for example Dictionary>>at:ifPresentAndInMemory:
On 2010-01-17, at 1:10 PM, Stéphane Ducasse wrote:
isInMemory
--
===========================================================================
John M. McIntosh <johnmci@smalltalkconsulting.com> Twitter: squeaker68882 Corporate Smalltalk Consulting Ltd. http://www.smalltalkconsulting.com
===========================================================================
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project