Why not rename Object>>assert: to should:, so it avoids breaking polymorphism, and keep TestCase>>assert: reserved for a boolean argument to stay compatible with SUnit in other dialects? On the negative side, it might not be as intuitive using should: for pre/post-assertions, as well as inconvenient to remember the difference between assert: and should: in TestCases. Not big enough negatives to outweigh the benefits though, imo. Cheers, Henry Stéphane Ducasse skrev:
The idea is that one day or later we will have to think about the benefit of pre and post condition. So assert: in object makes a lot of sense.
Now indeed it would be good that all the tests use assert: without block and use should: for that case.
Stef On Oct 15, 2009, at 3:55 AM, csrabak@bol.com.br wrote:
I don't either, but I find strange the complete hierarchy of classes of Pharo having a method assert: available. Perhaps I'm blindfolded and Pharo and Squeak have found a wider use for assertions?
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project