On Fri, 8 Oct 2010, Marcus Denker wrote:
On Oct 8, 2010, at 3:36 AM, Levente Uzonyi wrote:
On Thu, 7 Oct 2010, Alexander Lazarević wrote:
2010/10/7 Torsten Bergmann <astares@gmx.de>:
Dont know why this specific subclass was removed since other subclasses of AppRegistry are still in the image (like MailSender, SoundService, ...)
Was it by accident or if not what is the idea here.
It got nuked with
Name: System-Applications-StephaneDucasse.18 Author: StephaneDucasse Time: 11 July 2010, 6:52:54 pm UUID: 7eb6ce52-4ac4-4523-b44f-eaf822506c76 Ancestors: System-Applications-StephaneDucasse.14
- Issue 2664: empty classes: WebBrowser, SketchMorph, PasteUpMorphTest, NameOfSubclass, MethodTempsNode
Why did you remove NameOfSubclass?
It was part of the compiler tests, but there are no users (at least I am too dumb to find them).
-> empty class -> no References -> Not even in the source -> In a tests package -> Running the tests does not seem to re-create the class (else in addition, tearDown code would be needed)
It's part of the class creation template. The only useful aspect of its existence was that you got a warning if you forgot to change the name of the subclass in the template. Levente
Marcus
-- Marcus Denker -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project