I think FSLocator and FSReference are same objects: FSReference = fileSystem + path FSLocator = "some origin object" + path. I think "some origin object" can be implemented as special FSRelativeFileSystem. And fileLocator became fileReference. Now in "FSLocator vmDirectory" "some origin object" is symbol. And FileLocator>>resolve method perform some complex stuff through FSResolver hierarchy logic. What is purpose of FSResolver hierarchy? What is purpose of #resolve: and #resolve methods? Why so many classes (in FileSystem) implement it: FSLocator, FSReferece, FSPath, FSFileSystem, FSResolver? 2011/2/24 Max Leske <maxleske@gmail.com>
Maybe I'm just retelling a story but there is already a class called FSLocator. If FSReference would be renamed to FSLocation I think FSLocator would have to be renamed too.
Max
On 23.02.2011, at 00:28, Stéphane Ducasse wrote:
On Feb 21, 2011, at 2:54 PM, Denis Kudriashov wrote:
Hello,
I hear many people does not like name FSReference in FileSystem package.
Me too. Its not clear to me. But it is main object for end user.
Maybe we can rename it to FSLocation?
FSReference = FSSystem + FSPath So may be it could be renamed FSLocation.
I frequently name variables that point to some file/dir like
imagesLocation, settingsLocation and others. Therefore it is natural to me have FSLocation instead FSReference.
What do you think?