+1 2013/6/12 Guillaume Larcheveque <guillaume.larcheveque@gmail.com>
I think the simplest solution is to keep both and that flatCollect directly call gather:
If you agree with that, I will correct the moose extension package
2013/6/11 Stéphane Ducasse <stephane.ducasse@inria.fr>
gather: sucks as a name. flatCollect: is much better so do not remove it.
On Jun 11, 2013, at 4:53 PM, Sebastian Tleye <stleye@gmail.com> wrote:
If they are not different so a better way would be replace #flatenCollect: by #gather: but anyway, moose people should decide and commit the change since i am not a moose developer.
2013/6/11 Marcus Denker <marcus.denker@inria.fr>
On Jun 11, 2013, at 4:24 PM, Frank Shearar <frank.shearar@gmail.com> wrote:
On 11 June 2013 14:18, Sebastian Tleye <stleye@gmail.com> wrote:
Hello,
Fixing some bugs in Traits we realized that it would be good idea to use CollectionsExtensions package (it has some useful functions), also it would be great to include CollectionsExtensions in Pharo 3.0.
Is this the HPI library? I seem to recall TraitClasses [1] using it.
CollectionExtension is from Moose.
the Trait based Stream refactoring was done some years ago but has not been used or maintained.
Marcus
-- *Guillaume Larcheveque*