So victory I could unload completely Nautilus and RB :) Now I will be able to reload it and I will add some unload methods to the configurations and also to key classes. I think that configuration should have a protocol for that. I do not think that we should continue to not have configuration in the image because configurations are project metadata. to reproduce: rename Nautilus-History into History (MCWorkingCopy forPackage: (MCPackage named: 'NautilusRefactoring')) unload. Nautilus cleanUp. KMRepository reset. KMPragmaKeymapBuilder release. NautilusUI allInstances do: [ :inst | SystemAnnouncer uniqueInstance unsubscribe: inst]. Smalltalk garbageCollect. (MCWorkingCopy forPackage: (MCPackage named: 'NautilusCommon')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Nautilus')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Tests-Critics')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Tests-Core')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Tests-Environment')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Tests-Changes')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Spelling')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Critics')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Pharo-Platform')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Changes')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Core')) unload. (MCWorkingCopy forPackage: (MCPackage named: 'Refactoring-Environment')) unload. Stef