El dom, 30-08-2009 a las 22:27 +0200, Torsten Bergmann escribió:
Currently pharo packages are named differently:
- either "MyPackage" and "Tests-MyPackage" for the tests - or "MyPackage" and "MyPackage-Tests" for the tests - or something completely different like "GraphicsTests-Text"
First one is used more often but not very good when using the "alphabetize" functionality in the context menu of the standard browser ;)
Since the package naming scheme also affects - the monticello repo layouts - removal/shrink scripts (see ScriptLoader>>cleanupForProduction) - and method category names for extensions
we should agree on at least one to use.
I vote for the Seaside convention, summarized on: http://code.google.com/p/seaside/wiki/PackageNaming At leas, in my projects is the one I use and it sorts correctly on the package browsers and in the Monticello repos.
Were the pros and cons of the different naming schemes already discussed? If so is there any docu around? I remember Lukas suggested to use the one from Seaside...
Thx Torsten
-- Miguel Cobá http://miguel.leugim.com.mx