March 19, 2015
1:48 p.m.
On 19 Mar 2015, at 14:44, Ben Coman <btc@openInWorld.com> wrote:
So now in the image the remnants from the old DelayScheduler have been cleaned up by making it abstract with several methods becoming "subclassResponsibility".
Would it be a reasonable practice to group these in a protocol "subclass responsibility" to make it easier to determine what is needed for concrete subclasses? Or maybe append "subclass responsibility" to the original protocol of such methods?
no, normally this is not done⦠sometimes I wish we would have tags on methods instead of protocols. Then we could do both. Marcus