I started to enhance GLMAction that way (GLMGenericAction new) title: 'Cut'; action: [ :aPresentation | aPresentation cut ]; iconName: #smallCutIcon; shortcut: $x; withSeparatorBefore; yourself. Le 12/10/16 à 20:33, stepharo a écrit :
Le 12/10/16 à 20:09, Denis Kudriashov a écrit :
2016-10-12 20:06 GMT+02:00 stepharo <stepharo@free.fr <mailto:stepharo@free.fr>>:
In fact I do not really like iconNamed: as a name for a setter (for menu items and settings) May be it should be iconSelector: or buildIconNamed: because else we will confuse iconNamed: which returns an icon and iconNamed: that just sets the selector to retrieve the selector.
What do you think?
maybe #icon*Name:?*
*I see yes. I will think and change again all my fixes. Stef *