pharo-users@lists.pharo.org

Any question about pharo is welcome

View all threads

Recent Pharo's seem to lose first keystroke when you swap to them to paste?

TM
Tim Mackinnon
Mon, May 27, 2024 1:44 PM

For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. Tim
NB
Noury Bouraqadi
Mon, May 27, 2024 1:48 PM

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:

For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

Same bug on P11 with MacOS. On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: > For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. > > > This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? > > I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. > > Tim
KD
Koen De Hondt
Mon, May 27, 2024 2:01 PM

I have suffered from copy & paste issues like this for a long time, in P11 and P12.
I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:
For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

I have suffered from copy & paste issues like this for a long time, in P11 and P12. I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄 I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well. Koen > On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: > > Same bug on P11 with MacOS. > > On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: > For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. > > This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? > > I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. > > Tim
TM
Tim Mackinnon
Mon, May 27, 2024 3:02 PM

It would be handy to know if it’s just macOS - but I’ll write up an issue this evening.

Thanks for confirming.

Tim

On 27 May 2024, at 16:01, Koen De Hondt koen@all-objects-all-the-time.st wrote:

I have suffered from copy & paste issues like this for a long time, in P11 and P12.
I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:
For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

It would be handy to know if it’s just macOS - but I’ll write up an issue this evening. Thanks for confirming. Tim > On 27 May 2024, at 16:01, Koen De Hondt <koen@all-objects-all-the-time.st> wrote: > > I have suffered from copy & paste issues like this for a long time, in P11 and P12. > I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄 > > I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well. > > Koen > >> On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: >> >> Same bug on P11 with MacOS. >> >> On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: >> For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. >> >> This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? >> >> I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. >> >> Tim >
YC
Yanni Chiu
Mon, May 27, 2024 3:14 PM

It’s been happening for at least four years across updates of Pharo and
MacOS. At first it seemed random, but it is now so frequent as to require
pressing cmd-c twice, out of habit.

On Mon, May 27, 2024 at 10:01 AM Koen De Hondt <
koen@all-objects-all-the-time.st> wrote:

I have suffered from copy & paste issues like this for a long time, in P11
and P12.
I always have trouble with copying text from an image. I am already used
to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of
MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:

For a while I've noticed that every time I try and copy some text from a
web browser or email and then paste it into pharo the first time it fails -
and then thinking I didn't copy, I try it again and then realise that I
have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the
case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if
the same occurs in Windows or Linux or if its just my laptop? Its quite
annoying and I'm wondering if it might be a side effect from the gradual UI
changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for -
and so I wanted to canvas experience and then will report it.

Tim

It’s been happening for at least four years across updates of Pharo and MacOS. At first it seemed random, but it is now so frequent as to require pressing cmd-c twice, out of habit. On Mon, May 27, 2024 at 10:01 AM Koen De Hondt < koen@all-objects-all-the-time.st> wrote: > I have suffered from copy & paste issues like this for a long time, in P11 > and P12. > I always have trouble with copying text from an image. I am already used > to pressing Command-C twice 😄 > > I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of > MacOS as well. > > Koen > > On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: > > Same bug on P11 with MacOS. > > On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: > > For a while I've noticed that every time I try and copy some text from a > web browser or email and then paste it into pharo the first time it fails - > and then thinking I didn't copy, I try it again and then realise that I > have to paste twice - as the first one doesn't work. > > This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the > case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if > the same occurs in Windows or Linux or if its just my laptop? Its quite > annoying and I'm wondering if it might be a side effect from the gradual UI > changes in Pharo? > > I've looked in the issues tracker - but its a tricky thing to search for - > and so I wanted to canvas experience and then will report it. > > Tim > > >
DV
Davide Varvello
Mon, May 27, 2024 3:16 PM

Tim,
Also Pharo10 has this bug (mac m2, sonoma).

Thanks for your report!
Cheers
Davide 

On Monday, May 27, 2024 at 03:45:46 PM GMT+2, Tim Mackinnon tim@testit.works wrote:

For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

Tim, Also Pharo10 has this bug (mac m2, sonoma). Thanks for your report! Cheers Davide  On Monday, May 27, 2024 at 03:45:46 PM GMT+2, Tim Mackinnon <tim@testit.works> wrote: For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. Tim
TM
Tim Mackinnon
Mon, May 27, 2024 8:32 PM

I've submitted the issue https://github.com/pharo-project/pharo/issues/16700 and noted other comments

On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote:

It would be handy to know if it’s just macOS - but I’ll write up an issue this evening.

Thanks for confirming.

Tim

On 27 May 2024, at 16:01, Koen De Hondt koen@all-objects-all-the-time.st wrote:
I have suffered from copy & paste issues like this for a long time, in P11 and P12.
I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:

For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

I've submitted the issue https://github.com/pharo-project/pharo/issues/16700 and noted other comments On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote: > > It would be handy to know if it’s just macOS - but I’ll write up an issue this evening. > > Thanks for confirming. > > Tim > > >> On 27 May 2024, at 16:01, Koen De Hondt <koen@all-objects-all-the-time.st> wrote: >> I have suffered from copy & paste issues like this for a long time, in P11 and P12. >> I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄 >> >> I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well. >> >> Koen >> >>> On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: >>> >>> Same bug on P11 with MacOS. >>> >>> On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: >>>> For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. >>>> >>>> This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? >>>> >>>> I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. >>>> >>>> Tim
SD
stephane ducasse
Wed, May 29, 2024 10:29 AM

Tx
I did not know that pasting twice was working…
How a strange bug.

S

On 27 May 2024, at 22:32, Tim Mackinnon tim@testit.works wrote:

I've submitted the issue https://github.com/pharo-project/pharo/issues/16700 and noted other comments

On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote:

It would be handy to know if it’s just macOS - but I’ll write up an issue this evening.

Thanks for confirming.

Tim

On 27 May 2024, at 16:01, Koen De Hondt koen@all-objects-all-the-time.st wrote:
I have suffered from copy & paste issues like this for a long time, in P11 and P12.
I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:
For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

Stéphane Ducasse
http://stephane.ducasse.free.fr
06 30 93 66 73

"If you knew today was your last day on earth, what would you do differently? ....ESPECIALLY if, by doing something different, today might not be your last day on earth.” Calvin & Hobbes

Tx I did not know that pasting twice was working… How a strange bug. S > On 27 May 2024, at 22:32, Tim Mackinnon <tim@testit.works> wrote: > > I've submitted the issue https://github.com/pharo-project/pharo/issues/16700 and noted other comments > > On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote: >> >> It would be handy to know if it’s just macOS - but I’ll write up an issue this evening. >> >> Thanks for confirming. >> >> Tim >> >> >>> On 27 May 2024, at 16:01, Koen De Hondt <koen@all-objects-all-the-time.st> wrote: >>> I have suffered from copy & paste issues like this for a long time, in P11 and P12. >>> I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄 >>> >>> I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well. >>> >>> Koen >>> >>>> On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: >>>> >>>> Same bug on P11 with MacOS. >>>> >>>> On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: >>>> For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. >>>> >>>> This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? >>>> >>>> I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. >>>> >>>> Tim Stéphane Ducasse http://stephane.ducasse.free.fr 06 30 93 66 73 "If you knew today was your last day on earth, what would you do differently? ....ESPECIALLY if, by doing something different, today might not be your last day on earth.” Calvin & Hobbes
TM
Tim Mackinnon
Wed, May 29, 2024 1:03 PM

It's very stange - and it seems many people experience it from comments on the submitted but - although it seems an OSX problem (so far) and one that has happened possibly in P9 or P10.

Perhaps we can narrow it down enough to figure out the cause (and it occurs to me to see if GT has the same issue).

Tim

On Wed, 29 May 2024, at 12:29 PM, stephane ducasse wrote:

Tx
I did not know that pasting twice was working…
How a strange bug.

S

On 27 May 2024, at 22:32, Tim Mackinnon tim@testit.works wrote:

I've submitted the issue https://github.com/pharo-project/pharo/issues/16700 and noted other comments

On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote:

It would be handy to know if it’s just macOS - but I’ll write up an issue this evening.

Thanks for confirming.

Tim

On 27 May 2024, at 16:01, Koen De Hondt koen@all-objects-all-the-time.st wrote:
I have suffered from copy & paste issues like this for a long time, in P11 and P12.
I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:

For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it.

Tim

Stéphane Ducasse
http://stephane.ducasse.free.fr
06 30 93 66 73

"If you knew today was your last day on earth, what would you do differently? ....ESPECIALLY if, by doing something different, today might not be your last day on earth.” Calvin & Hobbes

It's very stange - and it seems many people experience it from comments on the submitted but - although it seems an OSX problem (so far) and one that has happened possibly in P9 or P10. Perhaps we can narrow it down enough to figure out the cause (and it occurs to me to see if GT has the same issue). Tim On Wed, 29 May 2024, at 12:29 PM, stephane ducasse wrote: > Tx > I did not know that pasting twice was working… > How a strange bug. > > S > >> On 27 May 2024, at 22:32, Tim Mackinnon <tim@testit.works> wrote: >> >> I've submitted the issue https://github.com/pharo-project/pharo/issues/16700 and noted other comments >> >> On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote: >>> >>> It would be handy to know if it’s just macOS - but I’ll write up an issue this evening. >>> >>> Thanks for confirming. >>> >>> Tim >>> >>> >>>> On 27 May 2024, at 16:01, Koen De Hondt <koen@all-objects-all-the-time.st> wrote: >>>> I have suffered from copy & paste issues like this for a long time, in P11 and P12. >>>> I always have trouble with copying text from an image. I am already used to pressing Command-C twice 😄 >>>> >>>> I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of MacOS as well. >>>> >>>> Koen >>>> >>>>> On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: >>>>> >>>>> Same bug on P11 with MacOS. >>>>> >>>>> On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: >>>>>> For a while I've noticed that every time I try and copy some text from a web browser or email and then paste it into pharo the first time it fails - and then thinking I didn't copy, I try it again and then realise that I have to paste twice - as the first one doesn't work. >>>>>> >>>>>> This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if the same occurs in Windows or Linux or if its just my laptop? Its quite annoying and I'm wondering if it might be a side effect from the gradual UI changes in Pharo? >>>>>> >>>>>> I've looked in the issues tracker - but its a tricky thing to search for - and so I wanted to canvas experience and then will report it. >>>>>> >>>>>> Tim > > Stéphane Ducasse > http://stephane.ducasse.free.fr > 06 30 93 66 73 > > "If you knew today was your last day on earth, what would you do differently? ....ESPECIALLY if, by doing something different, today might not be your last day on earth.” Calvin & Hobbes > >
RW
Russ Whaley
Sat, Jun 1, 2024 2:45 PM

I've paid specific attention to my pastes when an (outside of Pharo) window
is active... such as a web browser and I'm copying a URL, etc.  I find I
must select the Pharo window, THEN select the widget for the paste.  If I
just select the widget, it appears to be giving the window focus only, and
if I then selecting the widget, the paste works fine.

Hope this helps.
Russ

On Wed, May 29, 2024 at 9:03 AM Tim Mackinnon tim@testit.works wrote:

It's very stange - and it seems many people experience it from comments on
the submitted but - although it seems an OSX problem (so far) and one that
has happened possibly in P9 or P10.

Perhaps we can narrow it down enough to figure out the cause (and it
occurs to me to see if GT has the same issue).

Tim

On Wed, 29 May 2024, at 12:29 PM, stephane ducasse wrote:

Tx
I did not know that pasting twice was working…
How a strange bug.

S

On 27 May 2024, at 22:32, Tim Mackinnon tim@testit.works wrote:

I've submitted the issue
https://github.com/pharo-project/pharo/issues/16700 and noted other
comments

On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote:

It would be handy to know if it’s just macOS - but I’ll write up an issue
this evening.

Thanks for confirming.

Tim

On 27 May 2024, at 16:01, Koen De Hondt koen@all-objects-all-the-time.st
wrote:

I have suffered from copy & paste issues like this for a long time, in
P11 and P12.
I always have trouble with copying text from an image. I am already used
to pressing Command-C twice 😄

I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of
MacOS as well.

Koen

On 27 May 2024, at 15:48, Noury Bouraqadi bouraqadi@gmail.com wrote:

Same bug on P11 with MacOS.

On May 27 2024, at 3:44 pm, Tim Mackinnon tim@testit.works wrote:

For a while I've noticed that every time I try and copy some text from a
web browser or email and then paste it into pharo the first time it fails -
and then thinking I didn't copy, I try it again and then realise that I
have to paste twice - as the first one doesn't work.

This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the
case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if
the same occurs in Windows or Linux or if its just my laptop? Its quite
annoying and I'm wondering if it might be a side effect from the gradual UI
changes in Pharo?

I've looked in the issues tracker - but its a tricky thing to search for -
and so I wanted to canvas experience and then will report it.

Tim

Stéphane Ducasse
http://stephane.ducasse.free.fr
06 30 93 66 73

"If you knew today was your last day on earth, what would you do
differently? ....ESPECIALLY if, by doing something different, today
might not be your last day on earth.” Calvin & Hobbes

--
Russ Whaley
whaley.russ@gmail.com

I've paid specific attention to my pastes when an (outside of Pharo) window is active... such as a web browser and I'm copying a URL, etc. I find I must select the Pharo window, THEN select the widget for the paste. If I just select the widget, it appears to be giving the window focus only, and if I then selecting the widget, the paste works fine. Hope this helps. Russ On Wed, May 29, 2024 at 9:03 AM Tim Mackinnon <tim@testit.works> wrote: > It's very stange - and it seems many people experience it from comments on > the submitted but - although it seems an OSX problem (so far) and one that > has happened possibly in P9 or P10. > > Perhaps we can narrow it down enough to figure out the cause (and it > occurs to me to see if GT has the same issue). > > Tim > > On Wed, 29 May 2024, at 12:29 PM, stephane ducasse wrote: > > Tx > I did not know that pasting twice was working… > How a strange bug. > > S > > On 27 May 2024, at 22:32, Tim Mackinnon <tim@testit.works> wrote: > > I've submitted the issue > https://github.com/pharo-project/pharo/issues/16700 and noted other > comments > > On Mon, 27 May 2024, at 5:02 PM, Tim Mackinnon wrote: > > > It would be handy to know if it’s just macOS - but I’ll write up an issue > this evening. > > Thanks for confirming. > > Tim > > > On 27 May 2024, at 16:01, Koen De Hondt <koen@all-objects-all-the-time.st> > wrote: > > I have suffered from copy & paste issues like this for a long time, in > P11 and P12. > I always have trouble with copying text from an image. I am already used > to pressing Command-C twice 😄 > > I use a M2 Mac with MacOS 14.5, but it happened on earlier versions of > MacOS as well. > > Koen > > On 27 May 2024, at 15:48, Noury Bouraqadi <bouraqadi@gmail.com> wrote: > > Same bug on P11 with MacOS. > > On May 27 2024, at 3:44 pm, Tim Mackinnon <tim@testit.works> wrote: > > For a while I've noticed that every time I try and copy some text from a > web browser or email and then paste it into pharo the first time it fails - > and then thinking I didn't copy, I try it again and then realise that I > have to paste twice - as the first one doesn't work. > > This didn't seem to do this in Pharo 9 (maybe 10) but its definitely the > case in Pharo 11 and Pharo 12. This is on OSX (14.x) so I'm wondering if > the same occurs in Windows or Linux or if its just my laptop? Its quite > annoying and I'm wondering if it might be a side effect from the gradual UI > changes in Pharo? > > I've looked in the issues tracker - but its a tricky thing to search for - > and so I wanted to canvas experience and then will report it. > > Tim > > > Stéphane Ducasse > http://stephane.ducasse.free.fr > 06 30 93 66 73 > > "If you knew today was your last day on earth, what would you do > differently? ....ESPECIALLY if, by doing something different, today > might not be your last day on earth.” Calvin & Hobbes > > > > -- Russ Whaley whaley.russ@gmail.com