[Pharo-users] Attempting Pharo Book #3 WebApp Example on a 64-bit iMac

Bruce Prior b.prior at ieee.org
Wed Oct 28 19:22:40 EDT 2015

I worked my way through Sven van Caekenberghe's excellent tutorial on 
building and deploying a web app on Digital Ocean's cloud server. All 
went well at first, even though Digital Ocean didn't offer a Mac option 
(I picked Ubuntu Linux).

I skipped the Tests and Configuration parts of Sven's tutorial in order 
to get to the deployment part faster. I thought I could come back to 
those parts.

I was able to get SSH command line access to the new server and loaded 
Pharo using curl (See Sven's Section 12.3). But when I went to test the 
setup using
# ./pharo Pharo.image printVersion
I got an error saying pharo not found even though it was there in the 
pharo-vm directory.

I suspect that my attempt to do all this on an Apple iMac is the 
problem. Has anyone else tried using a Mac with Digital Ocean?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20151028/17c33844/attachment.html>

More information about the Pharo-users mailing list