<div dir="ltr">At the risk of being pedantic, if we were really serious, for mid term, it would be good to not compile ssl, but just link.<div><br></div><div><a href="https://www.cvedetails.com/vulnerability-list/vendor_id-217/product_id-383/opdos-1/Openssl-Openssl.html">https://www.cvedetails.com/vulnerability-list/vendor_id-217/product_id-383/opdos-1/Openssl-Openssl.html</a></div></div><br><div class="gmail_quote"><div dir="ltr">Le ven. 4 janv. 2019 à 10:13, Alistair Grant <<a href="mailto:akgrant0710@gmail.com">akgrant0710@gmail.com</a>> a écrit :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Hi Guille,<br>
<br>
On Fri, 4 Jan 2019 at 09:54, Guillermo Polito <<a href="mailto:guillermopolito@gmail.com" target="_blank">guillermopolito@gmail.com</a>> wrote:<br>
><br>
> Hi Alistair,<br>
><br>
> On Fri, Jan 4, 2019 at 9:25 AM Alistair Grant <<a href="mailto:akgrant0710@gmail.com" target="_blank">akgrant0710@gmail.com</a>> wrote:<br>
>><br>
>> Hi Esteban,<br>
>><br>
>> The VM is currently being built with libssh2 1.7.0, but this doesn't<br>
>> build on ARM v6 (Raspberry Pi) due to changes in openssl.<br>
>><br>
>> libssh2 1.8.0, which was released in October 2016, builds and appears<br>
>> to function correctly (the VM crashes when attempting to commit from<br>
>> within Iceberg, but I think this is an unrelated problem).<br>
><br>
><br>
> May I ask if you mean commit or push?<br>
<br>
I meant commit.  I guess that it is doing a comparison of the image to<br>
the git repository to determine what has changed (to present the<br>
dialog saying which methods have changed).  It's a call to free() that<br>
actually causes the problem.<br>
<br>
<br>
> Because commiting should not incure into any network activity and thus the ssl is never used.<br>
<br>
Which is why I thought it is unrelated :-)<br>
<br>
<br>
> I don't know about the satus of libssl and libgit, but it is certain that libgit uses libssl, so we have to be careful that the versions of libgit and libssl are compatible.<br>
<br>
I cloned the pharo repository as a basic check that they are working<br>
together (plus the testing on Ubuntu).<br>
<br>
<br>
>> I've built and done some ad-hoc testing of libssh2 1.8.0 on linux 64<br>
>> bit (Ubuntu 16.04) and haven't had any issues.<br>
>><br>
>> What do you think of upgrading from libssh2 1.7.0 to 1.8.0?<br>
>><br>
>> I don't know how close Pharo 7.0 is to release<br>
><br>
><br>
> Super close :)<br>
<br>
:-)<br>
<br>
Cheers,<br>
Alistair<br>
<br>
<br>
>> , but I expect this can<br>
>> wait until Pharo 8.0 if you prefer.<br>
><br>
><br>
> Or maybe for a 7.1?<br>
> We should be able to have easier and shorter release cycles in the future.<br>
><br>
> Thanks Alistair ^^<br>
><br>
>><br>
>> For convenience: <a href="https://www.libssh2.org/" rel="noreferrer" target="_blank">https://www.libssh2.org/</a><br>
>><br>
>> Thanks,<br>
>> Alistair<br>
>><br>
><br>
><br>
> --<br>
><br>
><br>
><br>
> Guille Polito<br>
><br>
> Research Engineer<br>
><br>
> Centre de Recherche en Informatique, Signal et Automatique de Lille<br>
><br>
> CRIStAL - UMR 9189<br>
><br>
> French National Center for Scientific Research - <a href="http://www.cnrs.fr" rel="noreferrer" target="_blank">http://www.cnrs.fr</a><br>
><br>
><br>
> Web: <a href="http://guillep.github.io" rel="noreferrer" target="_blank">http://guillep.github.io</a><br>
><br>
> Phone: +33 06 52 70 66 13<br>
<br>
</blockquote></div>