[Pharo-dev] New Latest VM - Please Test

Alistair Grant akgrant0710 at gmail.com
Sat Feb 1 02:32:37 EST 2020


Hi Pablo,

This VM looks like it will only run with Ubuntu 19.04 or later:

$ ./pharo --version
/dev/shm/p8/pharo-vm/lib/pharo/5.0-/pharo:
/lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found
(required by /dev/shm/p8/pharo-vm/lib/pharo/5.0-/pharo)

GLIBC 2.29 is delivered with Ubuntu 19.04.

Ubuntu 18.04 is the current LTS (GLIBC 2.27), and Ubuntu 16.04 is
still supported (GLIBC 2.23), so I'd expect that the VM is linked
against 2.23, or at least 2.27.

Cheers,
Alistair


> > Am 19.01.2020 um 19:10 schrieb tesonep at gmail.com:
> >
> > You are right Norbert, sorry I miss the data.
> > This is available through zeroConf.
> > Doing for example:
> >
> > wget -O - get.pharo.org/64/70+vmLatest | bash
> > wget -O - get.pharo.org/64/80+vmLatest | bash
> >
> > Cheers,
> > Pablo



More information about the Pharo-dev mailing list