[Pharo-dev] naming convention for pharo-vm/lib/pharo/* directory?
Sven Van Caekenberghe
sven at stfx.eu
Fri Jan 25 12:45:07 EST 2019
Maybe FileLocator can help ?
FileLocator vmDirectory pathString.
FileLocator vmBinary pathString.
$ ../bin/pharo Pharo.image eval 'FileLocator vmDirectory pathString'
$ ../bin/pharo Pharo.image eval 'FileLocator vmBinary pathString'
> On 25 Jan 2019, at 18:25, Dale Henrichs <dale.henrichs at gemtalksystems.com> wrote:
> Thanks Nicolas,
> Is it as simple as pharo/*, or could there be multiple directories created and I need to pick the right one?
> On 1/25/19 12:48 AM, Nicolas Cellier wrote:
>> I'm afraid it also depends on the overly complex rules burried deep inside the VM...
>> It would be a good thing to try and document it.
>> And if we can't reasonably document it, then we might want to open an issue on opensmalltalk.
>> Le ven. 25 janv. 2019 à 01:51, Dale Henrichs <dale.henrichs at gemtalksystems.com> a écrit :
>> I am in the process of porting the GemStone-GCI project to Pharo6.1
>> (32 bit) and Pharo7.0 (64 bit) and I'm curious what the naming
>> convention for the library directories are.
>> For Pharo5.0 and earlier, I copied my 32 bit gemstone gci library files
>> (.so on linux) into the pharo-vm directory.
>> For Pharo6.1 I just figured out that I need to copy the gci library
>> files into the pharo-vm/lib/pharo/5.0-201806281256 directory ... at list
>> the libraries are found when I do so?
>> I would like to be able to write a bash script that copies the gci
>> library files into the proper directory, but the directory for the
>> Pharo6.1 vm looks like some kind of magic number and I assume that
>> different builds of the 6.1 vm could have different names and possibly
>> even multiple directories under pharo-vm/lib/pharo/?
>> I haven't looked at Pharo7.0 yet to see what it's pharo-vm directory
>> structure looks like...
>> A pointer to where the naming conventions for these directories is
>> described for Pharo6.x, Pharo7.x and Pharo8.x would be greatly
>> appreciated ... would also be nice if the error message for the "module
>> not found" error could be a bit more descriptive as well ...
>>  https://github.com/GsDevKit/GemStone-GCI
More information about the Pharo-dev