[Pharo-dev] Apparently Zodiac plugin can crash VM on Linux

Max Leske maxleske at gmail.com
Tue Jan 15 16:20:46 EST 2019


Hi,

I'm writing on behalf of Martin (eMBee) who's experiencing crashes when 
using SSL. You can find a VM crash stack trace here: 
http://ws.stfx.eu/AKVNLUPMPGLG.

He says he hasn't updated openssl since December 15th but that the 
crashes started to happen only recently (within the last couple of 
days). I asked him to try HTTP only connections and those work. The VM 
crashes immediately when using SSL. To me it looks like the cuplrit is 
the Zodiac plugin, or at least the library it works with.

His system:
linux, fedora 29, and from the system reporter i get: 
Pharo/vms/70-x64/lib/pharo/5.0-201806281256/pharo
CoInterpreter VMMaker.oscog-eem.2401 uuid: 
29232e0e-c9e3-41d8-ae75-519db862e02c Jun 28 2018
StackToRegisterMappingCogit VMMaker.oscog-eem.2401 uuid: 
29232e0e-c9e3-41d8-ae75-519db862e02c Jun 28 2018
VM: 201806281256 https://github.com/OpenSmalltalk/opensmalltalk-vm.git 
Date: Thu Jun 28 14:56:30 2018 CommitHash: a8a1dc1 Plugins: 201806281256 
https://github.com/OpenSmalltalk/opensmalltalk-vm.git

cheers,
Max



More information about the Pharo-dev mailing list