[Pharo-dev] Pharo image don't restart

Eliot Miranda eliot.miranda at gmail.com
Thu Dec 13 12:23:57 EST 2018


Hi All,

> On Dec 13, 2018, at 5:40 AM, Christophe Demarey <christophe.demarey at inria.fr> wrote:
> 
> Hi,
> 
> The problem seems to come from: "no room in eden for allocateSmallNewSpaceSlots:format:classIndex:"

Then there should be a crash.dmp file that includes a stack trace.  I’m surprised the VM exists by this path; I would expect  the system to retry the allocation with an old space allocation that should work.

So, Dario, please keep a copy of your image and changes.  And please email me the crash.dmp file.  Create a clean one by deleting it first and then running the system until it fails and exits.  Multiple exits append to the crash.dmp file so it can end up being quite large.

> Eden is a part of the heap where new objects are allocated.
> Basically, it appears that Pharo cannot create objects any more.
> You can get information about gc and eden space here: https://clementbera.wordpress.com/2017/03/12/tuning-the-pharo-garbage-collector/
> 
> Could you try to run your image in headless mode to see if it starts?
> ex: 
> 
> I would try to start your image with a bigger size for the eden.
> Clément recommends to do: Smalltalk vm parameterAt: 45 put: (Smalltalk vm parameterAt: 44) * 4.
> but it means you need an image that is started …
> 
> You can also set it as an argument to the VM: --eden <size>[mk]
> 
> You could try with —eden 15207744 for example:
> ~/Documents/Pharo/vms/70-x64/Pharo.app/Contents/MacOS/Pharo --eden 15207744 ~/Documents/Pharo/images/Pharo\ 7.0\ -\ 64bit\ \(development\ version\)/Pharo\ 7.0\ -\ 64bit\ \(development\ version\).image 
> 
> Regards,
> Christophe
> 
> 
>> Le 13 déc. 2018 à 09:25, Trussardi Dario Romano <dario.trussardi at tiscali.it> a écrit :
>> 
>> Ciao,
>> 
>> 	i have a Ubuntu system
>> 		   where i defined a Pharo 7.0 - 64bit image managed with PharoLauncher.
>> 
>> 	I work with it for a month and all work fine.
>> 
>> 	Now after a save the image the system begin unstabled.
>> 
>> 	When the mouse go on the windows summary bar ( at the bottom of the Pharo window ) the image go down.
>> 
>> 	The first time i can launch the same image from the PharoLauncher,
>> 
>> 		but after a new  image  save ( the image go down ) i can't relaunch the image.
>> 
>> 	When i do the launch the pharoLauch shell report:
>> 
>> <errorePharo.txt>
>> 
>> 	I have some important work in the image ( and i don't have a backup )
>> 
>> 	Some consideration?
>> 
>> 	Thanks,
>> 		Dario
>> 
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20181213/92435d6b/attachment.html>


More information about the Pharo-dev mailing list