[Pharo-dev] Some segfault crashes and freezes when trying to re-run saved pharo 7 images

Clément Bera bera.clement at gmail.com
Tue Oct 24 05:47:48 EDT 2017


Hi again,

I checked with Stef this morning. Starting the image on a VM without
Freetype solves the problem. Just open the VM, remove or rename the
Freetype dynamic libraries (FT2, Freetype, 3 libs in total), then start
your image.

That's unfortunate the hexadecimal editor solution is so much more fun :-)

Cheers

On Sat, Oct 21, 2017 at 9:30 PM, Stephane Ducasse <stepharo.self at gmail.com>
wrote:

> Thanks thomas we should find the problem.
>
> Stef
>
> On Fri, Oct 20, 2017 at 3:57 PM, Thomas Dupriez
> <thomas.dupriez at ens-paris-saclay.fr> wrote:
> > Hello,
> >
> > I've had a few issues with Pharo 7 lately. After downloading pharo 7
> images,
> > doing some work in them and saving them, the images either instantly
> crashe
> > or freeze when I try to re-run them.
> > If that helps, I was working with and on the calypso browser.
> >
> > Attached are the crash dump files from some of these faulty images.
> >
> > vm version: 201708271955
> > image version: 6521
> > OS: Ubuntu 16.04 LTS
> >
> > Cheers,
> > Thomas
> >
>
>


-- 
Clément Béra
Pharo consortium engineer
https://clementbera.wordpress.com/
Bâtiment B 40, avenue Halley 59650 Villeneuve d'Ascq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20171024/3527c258/attachment-0002.html>


More information about the Pharo-dev mailing list