[Pharo-dev] Some segfault crashes and freezes when trying to re-run saved pharo 7 images

Clément Bera bera.clement at gmail.com
Fri Oct 20 12:54:21 EDT 2017


Hi,

As you can see in the crash dump, this is always due to FreeType. If it's
only at start-up it means it's in the FreeType start-up code. You can try
to change some free type settings (like not using those fonts at all) or to
use more hard-core scripts such as:

#(FT2Handle FreeTypeCache FreeTypeSettings) do: [ :each | SessionManager
default unregisterClassNamed: each  ]


On Fri, Oct 20, 2017 at 5:50 PM, Peter Uhnák <i.uhnak at gmail.com> wrote:

> I've experienced the same thing on Windows 10 yesterday, but normally I do
> not work in P7 so I didn't investigate much.
>
> On Fri, Oct 20, 2017 at 3:57 PM, Thomas Dupriez <thomas.dupriez at ens-paris-
> saclay.fr> wrote:
>
>> Hello,
>>
>> I've had a few issues with Pharo 7 lately. After downloading pharo 7
>> images, doing some work in them and saving them, the images either
>> instantly crashe or freeze when I try to re-run them.
>> If that helps, I was working with and on the calypso browser.
>>
>> Attached are the crash dump files from some of these faulty images.
>>
>> vm version: 201708271955
>> image version: 6521
>> OS: Ubuntu 16.04 LTS
>>
>> Cheers,
>> Thomas
>>
>>
>


-- 
Clément Béra
Pharo consortium engineer
https://clementbera.wordpress.com/
Bâtiment B 40, avenue Halley 59650 Villeneuve d'Ascq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20171020/988161d4/attachment-0002.html>


More information about the Pharo-dev mailing list