[Pharo-dev] I love the launcher!!!!

Norbert Hartl norbert at hartl.name
Thu Nov 30 08:01:05 EST 2017


Maybe we should make the pharo launcher move to opensuse build service as the vm did. This way it would be under the same umbrella and available for the main linux distributions

Norbert

> Am 30.11.2017 um 12:27 schrieb Christophe Demarey <christophe.demarey at inria.fr>:
> 
> Hi Eduardo,
> 
> Sadly, as far as I know, PPA are outdated, at least for pharo-launcher.
> That’s why it does not work. You have an old version using an old VM unable to open recent images.
> you should use http://files.pharo.org/platform/launcher/Pharo-linux-1.0.1.zip for now.
> 
> Christophe
> 
>> Le 30 nov. 2017 à 00:25, Eduardo de Oliveira Padoan <eduardo.padoan at gmail.com> a écrit :
>> 
>> I liked the launcher a lot, but It took me a while to get a version working out-of-the-box on Ubuntu.
>> 
>> It's not available with the VM on the /download page for Linux. My preferred choice would be the PPA anyway, as I like to keep stuff under APT control, but I had to dig a lot to find a sources.list entry combination that worked: not all packages are available on all repositories, and some old repos have invalid crypto signatures. In the end, what worked was:
>> 
>> - Xenial AND Trusty
>> deb http://ppa.launchpad.net/pharo/stable/ubuntu xenial main 
>> deb http://ppa.launchpad.net/pharo/stable/ubuntu trusty main
>> deb-src http://ppa.launchpad.net/pharo/stable/ubuntu xenial main 
>> deb-src http://ppa.launchpad.net/pharo/stable/ubuntu trusty main
>> 
>> - Disabled signatures checking (at my own risk):
>> sudo apt -o Acquire::AllowInsecureRepositories=true \
>>                                      -o Acquire::AllowDowngradeToInsecureRepositories=true \
>>                                      update
>> - Finally:
>> sudo apt install pharo-vm-core pharo-launcher 
>> 
>> But if I try to load a Pharo 5.0 image (created from the launcher's list, marked as beta), I get this on the terminal:
>> 
>> "This interpreter (vers. 6505) cannot read image file (vers. 6521)."
>> 
>> Pharo 4.0 is the most recent on that list that works, at least that I could find -- there are too many branches under Pharo Jenkins for instance, and I couldn't find a suitable image there.
>> 
>> 
>> Att,
>> 
>>> On Wed, Nov 29, 2017 at 5:13 PM Sean P. DeNigris <sean at clipperadams.com> wrote:
>>> demarey wrote
>>> > Maybe it could be related to this bug:
>>> > https://github.com/pharo-project/pharo-launcher/issues/52
>>> 
>>> It is a different bug in the same behavior.
>>> 
>>> The easy workaround is to manually create a pharo.version file for the
>>> offending image.
>>> 
>>> As to the bug…
>>> 
>>> The immediate problem turned out to be that I had a startup error in certain
>>> images due to a startup script that only worked in more recent Pharo
>>> versions. So, suggestion #1: check that pharo.version has actually been
>>> created, and if not produce a better error message. Also, ideally there
>>> should probably also be a timeout in determining the image version because
>>> sometimes the process returns without creating the file and other times it
>>> doesn't return at all.
>>> 
>>> However, even after disabling the startup scripts, I was only able to
>>> generate pharo.version by replacing
>>> "~/Documents/Pharo/vms/private/6505/Pharo.app" with
>>> "~/Documents/Pharo/vms/30-x86/Pharo.app", so there does also seem to be
>>> something fishy with the 6505 VM
>>> 
>>> 
>>> 
>>> -----
>>> Cheers,
>>> Sean
>>> --
>>> Sent from: http://forum.world.st/Pharo-Smalltalk-Developers-f1294837.html
>>> 
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20171130/85111c06/attachment-0002.html>


More information about the Pharo-dev mailing list