[Pharo-dev] Pharo 6.1 64 bits segmentation fault loading code on Linux

Thierry Goubier thierry.goubier at gmail.com
Tue Nov 21 15:39:40 EST 2017


Le 21/11/2017 à 21:00, Gabriel Cotelli a écrit :
> I can't find a latest 6.1 vm so I tried with the Pharo 7 Latest VM (wget 
> -O- get.pharo.org/64/vmTLatest70 <http://get.pharo.org/64/vmTLatest70> | 
> bash) and the 6.1 image but crashes with a segmentation fault also.

I also have a segfault with vmTLatest70.

At the moment, I use cog_linux64x64_pharo.cog.spur_201711061254, and 
this one doesn't segfault.

Otherwise, you can use the snap version of Pharo. This one doesn't 
segfault. You may have to install snap on your linux mint, and the snap 
has effect when you're calling external commands from Pharo.

Thierry

> 
> On Tue, Nov 21, 2017 at 12:03 PM, Thierry Goubier 
> <thierry.goubier at gmail.com <mailto:thierry.goubier at gmail.com>> wrote:
> 
>     Hi Gabriel,
> 
>     I had such segfaults with the stable 6.1/64bits on Linux. I solved
>     them by ensuring the use of a more recent version than the stable one.
> 
>     Thierry
> 
> 
>     2017-11-21 15:56 GMT+01:00 Gabriel Cotelli <g.cotelli at gmail.com
>     <mailto:g.cotelli at gmail.com>>:
> 
>         I've created the following issue:
> 
>         https://pharo.fogbugz.com/f/cases/20737/Segmentation-fault-trying-to-load-code-into-a-64-bits-Pharo-6-1-Linux
>         <https://pharo.fogbugz.com/f/cases/20737/Segmentation-fault-trying-to-load-code-into-a-64-bits-Pharo-6-1-Linux>
>         I can reproduce it easily so if you need some more info let me know.
> 
>         Regards,
>         Gabriel
> 
> 
> 





More information about the Pharo-dev mailing list