[Pharo-dev] About Collator
estebanlm at gmail.com
Sun Nov 5 04:16:29 EST 2017
> On 5 Nov 2017, at 06:00, Stephane Ducasse <stepharo.self at gmail.com> wrote:
> Hi guys
> Why do we rename class Sort to introduce terms that have unknown,
> unclear, undocumented meaning?
> To me PluggableSortFunction is MUCH better than CollatorBlockFunction.
but pluggable is also bad, IMO.
also I see there is some incoherence in the names:
ChainedSortFunction -> this is kind of ok, but I think a “ComposedSortFunction” is better.
SortByPropertyFunction -> shouldn’t be “PropertySortFunction” ? (coherent with the previous one)
CollatorSortFunction -> this is like a “BlockSortFunction” or “ValuableSortFunction” ?
More information about the Pharo-dev