[Pharo-dev] debugger broken?

Tudor Girba tudor at tudorgirba.com
Thu Jan 2 14:48:43 EST 2014


Yes, it worked. I just tried in a #30664 image.

Doru


On Thu, Jan 2, 2014 at 8:36 PM, Marcus Denker <marcus.denker at inria.fr>wrote:

>
> On 02 Jan 2014, at 20:25, Sebastian Sastre <sebastian at flowingconcept.com>
> wrote:
>
> Evaluating works now but I'm seeing this on #30668 doing cmd-s to accept
> code changes
>
> did it ever work on Pharo3? Just to know if this is a regression...
>
> <Screen Shot 2014-01-02 at 5.09.41 PM.png>
>
>
>
>
>
> On Dec 31, 2013, at 5:56 AM, Stéphane Ducasse <stephane.ducasse at inria.fr>
> wrote:
>
> Alex this is not the debugger this is the selection
>
> Have a look at issue 12144 load it and tell us. Now we have a problem of
> instability of the latest vm on our servers
> so the integration is stalled. I spent 3 hours yesterday trying to move on
> and we will rollback to an older VM.
>
>
> Stef
>
> On 30 Dec 2013, at 23:02, Alexandre Bergel <alexandre.bergel at me.com>
> wrote:
>
> Hi!
>
> I have faced a serious situation with the debugger today with Pharo 3.0:
> 1 - Open a workspace, and doit on the expression:  1 + 4. self halt
> 2 - Open the debugger, select with the mouse the expression 1 + 4 and
> press Cmd-p
> 3 - the debugger apparently consider the word halt as a variable.
>
> https://pharo.fogbugz.com/f/cases/12545/Debugger-broken
>
> Since I am using GTDebugger (in the Moose image), I have not seen it
> before...
>
> Cheers,
> Alexandre
>
> --
> _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
> Alexandre Bergel  http://www.bergel.eu
> ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
>
>
>
>
>
>
>
>
>


-- 
www.tudorgirba.com

"Every thing has its own flow"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20140102/6ea05e2a/attachment-0002.html>


More information about the Pharo-dev mailing list