[Pharo-dev] Suggestion on naming: shorter names

Sebastian Sastre sebastian at flowingconcept.com
Sat Oct 26 07:45:17 EDT 2013

Hi there,

I've saw this:

that you introduced:
valueWithInterval: aDelay
valueAfterWaiting: aDelay

which is a cool feature.

I only suggest that it could have shorter names.

Using: valueAfter: aDelay and valueEvery: aDelay

would make it look like:

[Transcript cr; show: 'Hello World!' ] valueAfter: 10 seconds.

[Transcript cr; show: 'tick-tack...' ] valueEvery: 10 seconds.

In general, and when they don't introduce ambiguity or unacceptable vagueness,  shorter names help typing, make the autocompleter find hits faster and unload the memory bandwidth of our brains

Keep the great work!



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20131026/9bdd4a29/attachment-0002.html>

More information about the Pharo-dev mailing list