[Pharo-dev] ShortRunArray not in Pharo 3.0 anymore, leading to problems with FFI-Kernel-tbn.25

phil at highoctane.be phil at highoctane.be
Wed Oct 9 14:29:00 EDT 2013


Well, no issues.

It is too complex for me to get things loaded in 3.0 and be delivering what
we need to, so I am back to 2.0 now.

Spent the day on dealing with configs and packages. I am more educated
about all that now anyway.

Phil



On Wed, Oct 9, 2013 at 7:43 PM, Stéphane Ducasse
<stephane.ducasse at inria.fr>wrote:

> Phil
>
> we are ready to help but then give the expression that shows the problem.
> May be this is just that snapshotcello was simply never loaded in 30
> because moose is in 20.
> and that there is just a platform definition missing.
>
> Stef
>
>
> Snashotcello not loading in 3.0 as well and the 2.x trick.
>
> Also, Gofer gives me some headaches when loading from directories.
>
> Phil
>
> -
> On Wed, Oct 9, 2013 at 4:05 PM, Esteban Lorenzano <estebanlm at gmail.com>wrote:
>
>>
>> On Oct 9, 2013, at 3:30 PM, Marcus Denker <marcus.denker at inria.fr> wrote:
>>
>> >
>> > On Oct 9, 2013, at 3:22 PM, phil at highoctane.be wrote:
>> >
>> >> There is an "ExternalObject class >>initialize" that attemps to place
>> itself after ShortRunArray, which isn't there, leasgin to "Error: nil
>> cannot be found in Smalltalk dictionary".
>> >>
>> >> Just to let you know,
>> >>
>> >
>> > Do we support non-nativeBoost FFI in Pharo3?
>>
>> not yet
>>
>> >
>> >
>> >> (Was testing the loading of my confs in 3.0 with the 2.0 monticello
>> trick".
>> >>
>> >> Phil
>> >
>>
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20131009/52032bb5/attachment-0002.html>


More information about the Pharo-dev mailing list