[Pharo-dev] Github and Pharo

GOUBIER Thierry thierry.goubier at cea.fr
Mon Nov 4 13:12:34 EST 2013

Hi Max,

I saw you were on it :) It's a huge effort you're undertaking. I learned a bit about git internal storage stepping through the code.


De : Pharo-dev [pharo-dev-bounces at lists.pharo.org] de la part de Max Leske [maxleske at gmail.com]
Date d'envoi : lundi 4 novembre 2013 17:44
À : Pharo Development List
Objet : Re: [Pharo-dev] Github and Pharo

FileSystem-Git is basically in alpha at the moment… I’m rewriting it.

On 04.11.2013, at 17:04, Goubier Thierry <thierry.goubier at cea.fr> wrote:

> Ok, I tried a bit with FileSystem-Git, but it seems there is still a bit of work to do...
> I tried on one of my work repository, and:
> - it failed trying to uft8convert a packed data file.
> So I corrected the error (get the stream as binary!) and
> - It failed looking for one of the commit IDs
> I found the ref in a pack file; apparently, it's not looking in there...
> I'm forcing a read of the pack files in there
> - Yet another utf8convert error on binary data
> Corrected, I got the pack files, but the index isn't telling me much.
> I tried to list the objects in it... Unknown compression method error.
> There's a huge amount of code in there, it's a bit frightening. I think I'll stay with OSProcess a bit longer ;)
> Thierry
> Le 04/11/2013 14:28, Goubier Thierry a écrit :
>> Le 04/11/2013 14:09, David T. Lewis a écrit :
>>> On Mon, Nov 04, 2013 at 01:58:29PM +0100, Goubier Thierry wrote:
>>>> Le 04/11/2013 12:11, kilon alios a ?crit :
>>>>> yeap filetree did the trick here. However it does not allow to browse
>>>>> through the git commits as gitfiletree does, the only commit available
>>>>> is the last commit.
>>>>> I took a look at CommandShell and friends and they all look pretty much
>>>>> very broken. For example in workspace I executed
>>>>> [ CommandShellTranscript open.] and trying "ls" or "dir" it creates an
>>>>> error because it add C path inside pharo subdirectories. Dont know if
>>>>> this is normal behavior.
>>> Use "CommandShell open" rather than "CommandShellTranscript open".
>>>> I hope someone with more knowledge than me of OSProcess under windows
>>>> will have a look :)
>>> OSProcess support for Windows is incomplete, so this will probably not
>>> do what you need. If the OSProcess is included in the Windows VM, it will
>>> let you run a Windows program, but it will not do most of the other
>>> things
>>> that you expect from OSProcess.
>>> Check http://www.squeaksource.com/ProcessWrapper.html for a possible
>>> alternative.
>> Thanks Dave; no easy solution on that, it seems. I'll have a look then
>> with FileSystem-Git, this one may be a more portable solution.
>> Windows is still a world apart from the rest :(
>> Thierry
> --
> Thierry Goubier
> CEA list
> Laboratoire des Fondations des Systèmes Temps Réel Embarqués
> 91191 Gif sur Yvette Cedex
> France
> Phone/Fax: +33 (0) 1 69 08 32 92 / 83 95

More information about the Pharo-dev mailing list