[Pharo-project] Trying to build CogVM in MacOSX 10.7 Lion

Nicolas Cellier nicolas.cellier.aka.nice at gmail.com
Sun Jan 29 04:39:44 EST 2012


2012/1/29 dimitris chloupis <thekilon at yahoo.co.uk>:
> ok if you want me to install the latest I will install the latest , but
> there is no such documentation I am aware of how to do that .
>
> Can you help me ?
>
> Currently I have NBCog , Pharo-1.4 image and the latest from " git clone
> git://gitorious.org/cogvm/blessed.git"
>
> But I have no idea how to install the latest VMMaker and CMakeVMMaker
>
> I tried monticello giving it this adress
>
> MCHttpRepository
>     location: 'http://www.squeaksource.com/VMMaker'
>     user: ''
>     password: ''
>

I agree with you, we are very very bad when it come to documenting how to...
To aggravate this situation, the ground is moving fast under our feet.
If you open above address in a web browser, you'll see this:

Effective 05-Sept-2011, the VMMaker repository is hosted at
http://source.squeak.org/VMMaker.html and new updates will appear in
that repository, possibly mirrored here for convenience. Please update
your Montecello browsers accordingly.

There is a Metacello invocation for loading all Pharo compatible or
Pharo specific packages maybe something like this (I'm not totally
sure, but Pharo gurus will correct me)

Gofer new
  squeaksource: 'MetacelloRepository';
  package: 'ConfigurationOfVMMaker';
  load.
(Smalltalk at: #ConfigurationOfVMMaker) perform: #load.

I don't have write access to these repositories, but I wish this
incantation were in the project description or the wiki of both pages
http://source.squeak.org/VMMaker.html and
http://www.squeaksource.com/VMMaker

I also see a notice about SVN, but nothing about the git repository...
I'm sure detailed instructions exist somewhere but a link should be
provided from the Monticello project page.
That's the least we should do, and not only for newbies (I often swear
like troopers when I loose my time searching the precious
information).
These little obstacles are repelling many people I guess, it's like we
should follow an initiation before we dare putting our dirty nose in
code.
I don't like this spirit, and I hope it's unintentional, but it's
totally contrary to Smalltalk foundations.

Nicolas

>
> Any package I click to load it gives me dependency issues and update package
> complains about a Bad
>
> Gateway
>
>
> Yes I got the very latest of XCode and I am open to any suggestion.
>
> ________________________________
> From: Igor Stasenko <siguctua at gmail.com>
> To: Pharo-project at lists.gforge.inria.fr
> Sent: Sunday, 29 January 2012, 1:00
> Subject: Re: [Pharo-project] Trying to build CogVM in MacOSX 10.7 Lion
>
>
>
> I don't know. But how do you know from his stackstrace that the problem is
> that ?
>
>
> i dont. :)
> i replied after seeing an Esteban's message saying that your post is
> outdated and one should use 3.9 config version.
> and couple days before we had someone who asking why NB-enabled VM fails to
> build for him,
> when he still using this magic
>  ((Smalltalk at: #ConfigurationOfVMMaker) project version: '1.5') load.
>
> while when i was released an CMakeVMMaker configs for NB , it was already
> far beyond that version,
> and of course won't work with 1.5.
>
> --
> Best regards,
> Igor Stasenko.
>
>




More information about the Pharo-dev mailing list