[Pharo-project] Cog+linux: external module not found

Paul DeBruicker pdebruic at gmail.com
Fri Jan 6 18:59:20 EST 2012


Schwab,Wilhelm K wrote
> 
> Eliot,
> 
> I'm getting the same error with your latest VM.  Any ideas?
> 
> Bill
> 
> 
> 

When I had trouble with this it was a 64bit vs 32bit library mismatch on a
64bit OS.  

Is it a 32 bit or 64 bit OS?  Is the library you're trying to reach 32bit? 
64bit libs won't work with the 32bit CogVM, but are installed by default by
the Ubuntu package manager on a 64bit Ubuntu. 

Ubuntu also moved some mandatory (from Cog's perspectvie) 32 bit libs from
their ia32-libs package to the ia32-libs-multiarch recently but I don't know
if that change affects Lucid.

--
View this message in context: http://forum.world.st/Cog-linux-external-module-not-found-tp4271136p4271354.html
Sent from the Pharo Smalltalk mailing list archive at Nabble.com.




More information about the Pharo-dev mailing list