[Pharo-project] Need help with ConfigurationOfCog

Igor Stasenko siguctua at gmail.com
Wed Jun 29 11:24:38 EDT 2011


Oh, sorry i didn't noticed that Esteban commited new version of
ConfigurationOfCog which takes priority (and its already has version
2.1 which caused this conflict).

On 29 June 2011 17:17, Igor Stasenko <siguctua at gmail.com> wrote:
> I updated the configuration to load new specs (ver 2.1),
> and everything worked before, but looks like after update of
> metacello, it does some checks and barks with error:
> Apparent loop in before/after dependency definitions
>
> any advice, what is wrong with it?
>
> The script to load stuff is following:
>
> Gofer new
>        squeaksource: 'MetacelloRepository';
>        package: 'ConfigurationOfCog';
>        load.
>
> ((Smalltalk at: #ConfigurationOfCog) project
>        version: '2.1') load.
>
> (Smalltalk saveAs: 'generator.image') ifFalse: [
>                                 Smalltalk snapshot: false andQuit: true]
>
> its used on hudson server to build VMs, and apparently worked before.
> And i'm clueless what exactly wrong (not expert with metacello).
> --
> Best regards,
> Igor Stasenko AKA sig.
>



-- 
Best regards,
Igor Stasenko AKA sig.




More information about the Pharo-dev mailing list