[Pharo-project] Issue 3595 in pharo: problem starting up with a script on windows

pharo at googlecode.com pharo at googlecode.com
Wed Jan 26 00:49:23 EST 2011


Status: Accepted
Owner: tudor.gi... at gmail.com
Labels: Milestone-1.2 Milestone-1.3 Type-ReportDefect

New issue 3595 by tudor.gi... at gmail.com: problem starting up with a script  
on windows
http://code.google.com/p/pharo/issues/detail?id=3595

Pharo image: Dev
Pharo core version: <copy from World/System/About>
Virtual machine used: Cog 2316, 2348


There seems to be a problem with starting a Pharo 1.2-based image with an  
initial .st script on Windows.

The problem seems to be in CodeLoader>>installSourceFiles and it is related  
to the contentStream retrieved from the HTTPDownloadRequest being nil. The  
debug log is listed below.

I checked the paths and they are all correct. In fact, if I run the same  
script with a Pharo 1.1.1 image, everything works as expected. I also tried  
to drag and drop the .st script and again, everything works as expected.  
So, it seems that there is some initialization problem.

I managed to debug some more and the problem seems to be introduced by  
System-Download after the version System-Download-StephaneDucasse.51. If  
you try any of the newer version, you should get the error.

I worked on a Windows Server 2008 R2 using a Cog VM (both r2316 and r2348).


Attachments:
	PharoDebug.log  7.8 KB





More information about the Pharo-dev mailing list