[Pharo-project] RBNodes accept vs. visit
stephane.ducasse at inria.fr
Tue Aug 23 12:56:50 EDT 2011
I would love to change that because this is terribly confusing for me that the
accept: and visit: methods are not well named.
On Aug 23, 2011, at 2:33 PM, Camillo Bruni wrote:
> Hi everyone,
> I just had a quick look at the RBNodes. Is there a particular reason why the visitor pattern methods are prefixed on both sides with 'accept'?
> RBArrayNode >> acceptVisitor: aProgramNodeVisitor
> ^ aProgramNodeVisitor acceptArrayNode: self
More information about the Pharo-dev