[Pharo-project] Pharo problem with Windows 7

Alexandre Bergel alexandre at bergel.eu
Thu Oct 21 16:44:16 EDT 2010

This is really strange.
We've tried for a while to save a rep on a local repository, on squeaksource, no success...

Anyone experienced this already?


On 21 Oct 2010, at 17:30, Christian Eduardo Palomares Peralta wrote:

> Hi everyone
> I'm new on Pharo, i downloaded pharo for Windows (http://pharo-project.org/pharo-download), everything works fine until i try to save a package in the Monticello Browser, the "Snapshotting Methods" takes age. Several minutes pass and nothing is saved. Selecting a local repository does not help neither in case squeaksource would be down.
> I use the VM 4.0.2. I tried the Pharo1.1 one click image, the Windows Installer, and the Seaside One click image. Same result.
> When I press Alt-. the debugger always open on the  retryWithGC: in the method:
> MultiByteFileStream>>open: fileName forWrite: writeMode 
> 	"Open the file with the given name. If writeMode is true, allow writing, otherwise open the file in read-only mode."
> 	"Changed to do a GC and retry before failing ar 3/21/98 17:25"
> 	| f |
> 	f := fileName asVmPathName.
> 	fileID := StandardFileStream retryWithGC:[self primOpen: f writable: writeMode] 
> 					until:[:id| id notNil] 
> 					forFileNamed: fileName.
> I disabled my antivirus, but the problem persist
> Does anyone can help me with this problem?
> Thxs
> -- 
> Christian Eduardo Palomares Peralta (ShinjiDev) - http://learningwebdev.blogspot.com
> Administrador del Grupo Python-Perú
> _______________________________________________
> Pharo-project mailing list
> Pharo-project at lists.gforge.inria.fr
> http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project

Alexandre Bergel  http://www.bergel.eu

More information about the Pharo-dev mailing list