[Pharo-project] Pharo problem with Windows 7

Christian Eduardo Palomares Peralta palomares.c at gmail.com
Thu Oct 21 16:30:44 EDT 2010

Hi everyone

I'm new on Pharo, i downloaded pharo for Windows (
http://pharo-project.org/pharo-download), everything works fine until i try
to save a package in the Monticello Browser, the "Snapshotting Methods"
takes age. Several minutes pass and nothing is saved. Selecting a local
repository does not help neither in case squeaksource would be down.

I use the VM 4.0.2. I tried the Pharo1.1 one click image, the Windows
Installer, and the Seaside One click image. Same result.

When I press Alt-. the debugger always open on the  retryWithGC: in the
MultiByteFileStream>>open: fileName forWrite: writeMode
"Open the file with the given name. If writeMode is true, allow writing,
otherwise open the file in read-only mode."
"Changed to do a GC and retry before failing ar 3/21/98 17:25"
| f |
f := fileName asVmPathName.

fileID := StandardFileStream retryWithGC:[self primOpen: f writable:
until:[:id| id notNil]
forFileNamed: fileName.

I disabled my antivirus, but the problem persist

Does anyone can help me with this problem?


Christian Eduardo Palomares Peralta (ShinjiDev) -
Administrador del Grupo Python-Perú
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20101021/193a2726/attachment-0001.html>

More information about the Pharo-dev mailing list