[Pharo-project] question about Issue 207: ImageSegment discoverActiveClasses strange error

Stéphane Ducasse stephane.ducasse at inria.fr
Sun Sep 6 15:05:28 EDT 2009


Sheridan
if you want you can commit in the pharoTaskForces project.
Like that your work is not mixed with the incoming flow of the inbox
that I try to keep as clean as possible.

>
>
>> On Sep 5, 2009, at 3:10 AM, sheridan at sheridan-mahoney.com wrote:
>
> [...]
>
>>
>>> I have found a report that seems quite interesting, and have done
>>> some digging into the issue described here:
>>> http://code.google.com/p/pharo/issues/detail?id=207
>>> ( ImageSegment discoverActiveClasses strange error )
>>> and now I have a few questions I was hoping to get feedback on.
>>
>>
>> We would love to have a couple of tests for imagesegment!!!!
>> Adrian did you publish the ones you did?
>
> I committed my image segment tests to the inbox (Tests-AdrianLienhard.
> 19). There are some initial tests in ImageSegmentTest (one fails,
> which documents a problem of loading symbols). I also implemented
> support code that allows one to analyze a segment binary (i.e., to
> iterate over the instances in the segment without instantiating the
> objects). This should simplify writing more tests.
>
> Cheers,
> Adrian
>
> [...]
>
>
> ___________________
> http://www.adrian-lienhard.ch/
>
>
> _______________________________________________
> Pharo-project mailing list
> Pharo-project at lists.gforge.inria.fr
> http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project





More information about the Pharo-dev mailing list