[Pharo-project] About RBProgramNodeVisitor interface
stephane.ducasse at inria.fr
Tue Jan 20 11:47:37 EST 2009
I was reading RBProgramNodeVisitor and I do not like the fact that we
have name of the methods
is not consistent with the GOF.
I do not like that the visitor methods are named accept* and in
addition the visitMethod of RB are not
what you think they should.
I know it was done before GOF but I would really like to
I would like to have the visitMethod in the visitor and the accept in
May be it would be better to rewrite another one and start to use it
What do you think?
More information about the Pharo-dev