On Mon, Apr 27, 2015 at 3:19 AM, Tudor Girba <tudor@tudorgirba.com> wrote:
Hi,

There already exists a GT-InspectorExtensions-XML which is already published in the GT repository.

Cool. I'll revert my changes.�� However its not very discoverable that people need to check that repository for any particular application.�� I even took a few guesses to find the repository Smalltalkhub/Moose/GToolkit.�� Also, I understand from...
http://pharo.gemtalksystems.com/book/LanguageAndLibraries/XML/XML-support-in-Pharo/
that there are different XML packages, so its not obvious from your package which system it applies to. Though from context here I guess it is XML-Parser, others coming later won't have that context. ��(I guess a separate GT-InspectorExtensions-* package is needed for each XML system.)

Now when I add some GT extensions to my own package, should I put my GT-InspectorExtensions-MyApplication package in your repository? And can I have write access to maintain it ;) ? �� It would be good to manage these extensions consistently across the community. ��

So what do you think of...
* Updating ConfigurationOfXMLParser to automatically load the extensions for Pharo4.
* Moving the package into the XML-Parser repository so it sits next to other compatibility packages like XML-Parser-GemstoneCompatability -- and possibly renaming it something like XML-Parser-GT-Extensions.



I would prefer to qualify the extensions by the tool they refer to: GT-InspectorExtensions-*, GT-SpotterExtensions-* etc.

gtDisplayOn: should be more in the inspector, but probably some were added mostly in the spotter so they ended up in the less optimal package.

okay. good to understand.
cheers -ben

��

Cheers,
Doru



On Sun, Apr 26, 2015 at 8:30 PM, Ben Coman <btc@openinworld.com> wrote:
I happened to need to use and XML Parser for the first time and found inspecting the structure awkward, so I added some GTInspector extensions to XML-Parser. This is uploaded as XML-Parser-BenComan.304 to��http://smalltalkhub.com/#!/~PharoExtras/XMLParser.�� Could someone who uses XML regularly check if these are reasonable?

Now should these methods be packaged separately somehow, since they are likely not of interest to other Smalltalk flavours? ����

btw I gave them a protocol of "GT-Extensions" - but I also considered "moldable-tools" and "tools-extensions".�� If there a preference?�� This will likely be a common occurrence across the community, so we should try for a consistent convention across the community for such extensions.

btw2, I notice that #gtDisplayOn: implementors are fairly evenly split between [GT-InspectorExtensions-Core] and [GT-SpotterExtensions-Core].�� Are they really separated like this in their use?

cheers -ben



--

"Every thing has its own flow"