2014-11-23 15:15 GMT+01:00 Peter Uhn��k <i.uhnak@gmail.com>:
So I accidentally assigned some content to 'layout' variable in class side and realized much later that it has overridden some Slot's FixedLayout.

Looking up the inheritance chain (Object & ProtoObject) I couldn't find anything so I don't know where is this coming from or how it is added there.

But most importantly: are there more variable names that I should be aware of that could get accidentally overridden?

Thanks,
Peter


Yes, that is a problem, and there is already an issue at fogbugz:

11783
#layout should be renamed to e.g. #slotLayout
(actually, it is renamed to classLayout)

and there are other messages like #users for trait users
13274
Replace users by traitUsers