I saw a tweet about that, and I think that the example is misleading, maybe intentionally so.

I don't think anybody would model it that way, in any case you'd have aProduct.buy() or aProduct.addToCart(aCart).��

If you think it with the typical dog.bark() it certainly makes more sense than bark(dog).

Regards!

Esteban A. Maringolo


On Fri, Apr 16, 2021 at 5:20 AM Tim Mackinnon <tim@testit.works> wrote:
Hi guys - someone pointed out this article from a UK colleague which seems to be causing a flurry of discussion - but I always like the insights of this group. I had an instant reaction when I read it - but curious what people here think in 2021.

https://www.linkedin.com/posts/jasongorman_the-year-is-2021-and-people-still-think-activity-6787650079764303872-SJzz

Tim