On Mon, May 2, 2011 at 8:20 PM, Ramon Leon <ramon.leon@allresnet.com> wrote:
On 05/02/2011 05:41 AM, Markus Fritsche wrote:
Hello,

become replaces all pointers to the object to point to some other
object.

Actually, that's what #becomeForward: does, #become: swaps two objects replacing all pointers to the object to point to some other object and vice versa, which can cause serious issues if you aren't expecting it. #becomeForward: is quite often the behavior you'd want when you think you need #become:.


You know, I always thoguht that #become: is a bad name. For me, #becomeForward:� should be called #become� and, #become should be called #replace: or #swaps:�� or something like that, but to make clear that it is both sides :)
--
Ramon Leon
http://onsmalltalk.com





--
Mariano
http://marianopeck.wordpress.com