Hi,

We are working on a more elaborate model for examples, but we need a bit more time to get to a rounder solution.

Cheers,
Doru



On Mon, Jun 22, 2015 at 12:49 PM, Nicolai Hess <nicolaihess@web.de> wrote:


2015-06-22 12:03 GMT+02:00 Peter Uhn��k <i.uhnak@gmail.com>:
Hi,

there was a long discussion about the meaning of example* methods and <example> pragmas, however I do not know what was the final resolution.

Basically I am interested in two use-cases

1. executable example (the one where Nautilus shows nice play icon)
This is as I understand only through example* naming (on class-side).

Yes, but I would like to use a pragma again and don't rely naming convention, we just wasn't able to agree on one.
��

2. returning examples (example that returns some value that I can reuse)
Is this what <example> pragma is for? How would I go about naming it considering that having play icon there would be counter-productive (user would be clicking on it and nothing would happen).

Inspector and spotter use gtExample* names in addition to an <gtExample> pragma.
<gtExample> -> for finding those methods
gtExample*name -> for not getting the play icon.

This is less than perfect.
��

Thanks,
Peter




--
www.tudorgirba.com

"Every thing has its own flow"