On 5 Jul 2018, at 09:40, Guillermo Polito <guillermopolito@gmail.com> wrote:Hi Dario,Have you defined those methods in the class side?a) propertyAt: aKey ifAbsent: aBlock
^ self properties at: aKey ifAbsent: aBlock
b) propertyAt: aKey ifAbsentPut: aBlock
^ self properties at: aKey ifAbsentPut: aBlock
c) propertyAt: aKey put: aValue
^ self properties at: aKey put: aValueI will let Marcus answer more properly but I think you should rename those methods to not collapse with the behaviour in the base class...