From design point of view I think we should remove adapters at all. They bring parallel hierarchy which is always bad.
In fact they are not adapters. They are factories which creates backend views (morphs). And now there are completely no logic behind them: every adapter just passes state received from model to view instance.
I think full hierarchy of adapters can be easily substituted by single backend factory class like MorphicViewFactory. Every model will ask it to create concrete view instance. Actually I have another idea: we do not need this factory at all.
Now Spec allows very restricted relationship between model and view. We can only have single kind of view per model (MorphicAdapterBindings defines this relation). There is no way to use different kind of views for same model in single application.
Maybe current design tried to address this issue. But it not works. And interesting that all Spec based tools do not require such kind of flexibility which means that it is not really an issue.��
Now you can imaging that if we always use same view class for same model class then we can directly ask model to instantiate view. Message can be backend specific like createMorphicView: and we need hierarchy of backends here which will choose appropriate message.
P.S. Every time I read word model in Spec I feel something bad. It should be named to presenter. But it is quite difficult due to compatibility. And I am not sure that others agree with this.