I do not like either the ���virus��� name.��not just because is negative in a subjective way��� also it hides what it does inside a fantasy name, and that IMO is negative to self discovery of the system.��I mean��� a framework can have a fantasy name��� but a class? A method name? (#infect:��� come on!)��I know is ���cool", but if I read the code below, I have NO CLUE of what is going to happen, and that���s not good.
virus := GHObjectVirus behaviour: GHGhostBehaviourStub new.
�� ����
victim := 0@0 corner: 3@4.
virus infect: victim.
mutation := GHObjectMutation behaviour: GHGhostBehaviourStub new.victim := 0@0 corner: 3@4.mutation infect: victim.