@olivier
I guess that playing to test them should be considered to work.
@kilon
Mail me back if you do develop a game adding from you graphical capabilities.
@stepharo ,��Ben��
Code review would be nice!
I've tried to chose the most meaningful names, yet i didn't discuss this with anyone, what would be adequate since communication is interpersonal. If you show me, telling why, you think another name would communicate better instead a current one i'll change it. Also i'd like more people to have an opinion on this.
I agree that games' director names are meaningless, seems that something like '(BG)DirectorOfGameName' would communicate better and be more practical since when you type 'BGDirector' code completition will show all the existing game director subclasses, that is all the games.
@stepharo
I subclass from��Matrix��BGBoardSpace and��DPPieceLayout. These ��are respectively��matrix arrangements of places (BGBoardPlace) and squares (DPSquare) that (potentially) need to understand all��Matrix��interface in addition to extending it (for example class side methods for instantiating particular space cases like level spaces, instance side methods for telling space properties). I think it's like having to model��matrix��of numbers that would need to support all math��matrix��operations, why not to subclass? why to rewrite all��matrix��interface?
Composition takes place at the level of BGBoard and��DPPiece (which are respectively composed by aBGBoardSpace and aDPPieceLayout), so substitution could occur there if you need a non��matrix��space (is that to be expected?).
Why do you think composing��BGBoardSpace and��DPPieceLayout would be better?