Pattern?�� I'd call it an antipattern myself.
Note that we can already construct
�� { block1
�� . block2
�� . block3
�� }
and write
�� { block1
�� . block2
�� . block3
�� } allSatisfy: [:each | each value].
so we don't have to abuse the #, selector
or write a single new method to get the "flattened"
structure you're after.
Collection
�� methods for: 'collections of blocks'
������ allSatisfied
���������� ^self allSatisfy: [:each | each value]
������ anySatisfied
���������� ^self anySatisfy: [:each | each value]
������ noneSatisfied
���������� ^self noneSatisfy: [:each | each value]
if you do feel like adding a few methods, whereupon
�� { block1
�� . block2
�� . block3
�� } allSatisfied
Didn't VW recently implement {} syntax natively?
Or was that VAST?
In all seriousness, when is it better to use
ComplexCondition than to rewrite?