[pharo-project/pharo-core] a400d2: 30558
Branch: refs/heads/3.0 Home: https://github.com/pharo-project/pharo-core Commit: a400d2cd03f9c62dfa2406497ef0acaa48b19973 https://github.com/pharo-project/pharo-core/commit/a400d2cd03f9c62dfa2406497... Author: Jenkins Build Server <board@pharo-project.org> Date: 2013-11-08 (Fri, 08 Nov 2013) Changed paths: A Collections-Weak.package/WeakIdentityKeyDictionary.class/instance/enumeration/valuesDo_.st A Collections-Weak.package/WeakKeyDictionary.class/instance/enumerating/valuesDo_.st A Collections-Weak.package/WeakValueDictionary.class/instance/enumerating/valuesDo_.st M Monticello.package/extension/Class/instance/asClassDefinition.st M MonticelloGUI.package/extension/PseudoClass/instance/asClassDefinition.st M NautilusRefactoring.package/RBClassRegexRefactoring.class/instance/private/copyFrom_to_.st R Refactoring-Changes.package/RBAddClassChange.class/instance/accessing/poolDictionaryNames.st A Refactoring-Changes.package/RBAddClassChange.class/instance/accessing/sharedPoolNames.st M Refactoring-Core.package/RBChildrenToSiblingsRefactoring.class/instance/private-variables/pullUpPoolVariables.st M Refactoring-Core.package/RBClass.class/instance/accessing/allPoolDictionaryNames.st M Refactoring-Core.package/RBClass.class/instance/accessing/definitionString.st R Refactoring-Core.package/RBClass.class/instance/accessing/poolDictionaryNames.st A Refactoring-Core.package/RBClass.class/instance/accessing/sharedPoolNames.st M Refactoring-Core.package/RBClass.class/instance/testing/directlyDefinesPoolDictionary_.st M Refactoring-Core.package/RBNamespace.class/instance/changes/defineClass_.st M Refactoring-Critics.package/RBClassVariableCapitalizationRule.class/instance/running/checkClass_.st M Refactoring-Tests-Changes.package/RBRefactoringChangeTests.class/instance/tests-pattern/testAddClassPattern.st M Refactoring-Tests-Changes.package/RBRefactoringChangeTests.class/instance/tests/testAddClassInteractively.st M Ring-Core-Kernel.package/extension/Class/instance/asRingDefinition.st A ScriptLoader30.package/ScriptLoader.class/instance/pharo - scripts/script214.st A ScriptLoader30.package/ScriptLoader.class/instance/pharo - updates/update30558.st M ScriptLoader30.package/ScriptLoader.class/instance/public/commentForCurrentUpdate.st M System-Announcements.package/ClassCommented.class/instance/accessing/oldComment.st R Traits.package/TBehavior.class/instance/accessing/poolDictionaryNames.st A Traits.package/TBehavior.class/instance/accessing/sharedPoolNames.st Log Message: ----------- 30558 12102 Optimize Dictionary>>valuesDo:, part 1 https://pharo.fogbugz.com/f/cases/12102 12112 Missing ^ in accessor method in ClassCommented https://pharo.fogbugz.com/f/cases/12112 12099 Rename #poolDictionaryNames to #sharedPoolNames https://pharo.fogbugz.com/f/cases/12099 http://files.pharo.org/image/30/30558.zip
participants (1)
-
GitHub