[Pharo-project] Reintegration of StringSocket
Hi, StringSocket is a class part of Nebraska. You removed that class. However, Universe uses this class to publish packages. Is it possible to reintegrate this class, at least partially to support Universe? Bye -- Damien Cassou Peter von der Ahé: «I'm beginning to see why Gilad wished us good luck». (http://blogs.sun.com/ahe/entry/override_snafu)
sure can you publish it somewhere? Stef On Jun 13, 2008, at 3:39 PM, Damien Cassou wrote:
Hi,
StringSocket is a class part of Nebraska. You removed that class. However, Universe uses this class to publish packages. Is it possible to reintegrate this class, at least partially to support Universe?
Bye
-- Damien Cassou Peter von der Ahé: «I'm beginning to see why Gilad wished us good luck». (http://blogs.sun.com/ahe/entry/override_snafu)
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
Stéphane Ducasse wrote:
sure can you publish it somewhere?
Stef
On Jun 13, 2008, at 3:39 PM, Damien Cassou wrote:
Hi,
StringSocket is a class part of Nebraska. You removed that class. However, Universe uses this class to publish packages. Is it possible to reintegrate this class, at least partially to support Universe?
I would rather vote for rewrite Universes to not use. Special subclasses of Socket are plain evil ;-) Michael
Ok but what is the solution right now to make universe work? Damien may be you should include StringSocket into the Universe package. Because it is strange to rely on nebraska. stef On Jun 14, 2008, at 4:51 AM, Michael Rueger wrote:
Stéphane Ducasse wrote:
sure can you publish it somewhere? Stef On Jun 13, 2008, at 3:39 PM, Damien Cassou wrote:
Hi,
StringSocket is a class part of Nebraska. You removed that class. However, Universe uses this class to publish packages. Is it possible to reintegrate this class, at least partially to support Universe?
I would rather vote for rewrite Universes to not use. Special subclasses of Socket are plain evil ;-)
Michael
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
On Sat, 2008-06-14 at 09:25 +0200, Stéphane Ducasse wrote:
Ok but what is the solution right now to make universe work? Damien may be you should include StringSocket into the Universe package. Because it is strange to rely on nebraska.
It is not a problem if you want to only use universe for reading. As Damien told me StringSocket is only used if you update the map. The warning is ugly anyway. Norbert
stef
On Jun 14, 2008, at 4:51 AM, Michael Rueger wrote:
Stéphane Ducasse wrote:
sure can you publish it somewhere? Stef On Jun 13, 2008, at 3:39 PM, Damien Cassou wrote:
Hi,
StringSocket is a class part of Nebraska. You removed that class. However, Universe uses this class to publish packages. Is it possible to reintegrate this class, at least partially to support Universe?
I would rather vote for rewrite Universes to not use. Special subclasses of Socket are plain evil ;-)
Michael
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
On Sat, Jun 14, 2008 at 9:25 AM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote:
Ok but what is the solution right now to make universe work? Damien may be you should include StringSocket into the Universe package. Because it is strange to rely on nebraska.
I will try to see what I can do. -- Damien Cassou Peter von der Ahé: «I'm beginning to see why Gilad wished us good luck». (http://blogs.sun.com/ahe/entry/override_snafu)
I notice that StringSocket inherits from ObjectSocket and then Stream... so StringSocketStream might have been a better name for it.... Gary.
-----Original Message----- From: pharo-project-bounces@lists.gforge.inria.fr [mailto:pharo-project-bounces@lists.gforge.inria.fr]On Behalf Of Michael Rueger Sent: 14 June 2008 3:52 AM To: An open mailing list to discuss any topics related to an open-sourceSmalltalk Subject: Re: [Pharo-project] Reintegration of StringSocket
Stéphane Ducasse wrote:
sure can you publish it somewhere?
Stef
On Jun 13, 2008, at 3:39 PM, Damien Cassou wrote:
Hi,
StringSocket is a class part of Nebraska. You removed that class. However, Universe uses this class to publish packages. Is it possible to reintegrate this class, at least partially to support Universe?
I would rather vote for rewrite Universes to not use. Special subclasses of Socket are plain evil ;-)
Michael
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
On Sat, Jun 14, 2008 at 9:25 AM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote:
Ok but what is the solution right now to make universe work? Damien may be you should include StringSocket into the Universe package. Because it is strange to rely on nebraska.
I've just published a new version of Universes which includes StringSocket and its super class ObjectSocket (renamed StringSocketStream and ObjectSocketStream). I have also replaced direct references to other Nebraska classes (CanvasEncoder and NebraskaDebuger) to: Smalltalk at: #NebraskaDebugger ifPresent: [:debug | debug ...]. It seems to me these classes were only used to log things. Do you agree Lex? -- Damien Cassou Peter von der Ahé: «I'm beginning to see why Gilad wished us good luck». (http://blogs.sun.com/ahe/entry/override_snafu)
On Tue, Jun 17, 2008 at 3:41 PM, Damien Cassou <damien.cassou@gmail.com> wrote:
I've just published a new version of Universes which includes StringSocket and its super class ObjectSocket (renamed StringSocketStream and ObjectSocketStream). I have also replaced direct references to other Nebraska classes (CanvasEncoder and NebraskaDebuger) to:
Smalltalk at: #NebraskaDebugger ifPresent: [:debug | debug ...].
It seems to me these classes were only used to log things. Do you agree Lex?
From Lex who is not on the list: «Yes, that looks like a great change. Also, I like the general strategy of splitting StringSocket from Nebraska. StringSocket was always meant to be usable by itself.»
-- Damien Cassou Peter von der Ahé: «I'm beginning to see why Gilad wished us good luck». (http://blogs.sun.com/ahe/entry/override_snafu)
participants (5)
-
Damien Cassou -
Gary Chambers -
Michael Rueger -
Norbert Hartl -
Stéphane Ducasse